summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorClinton Stimpson <clinton@elemtech.com>2014-12-26 21:25:20 -0700
committerBrad King <brad.king@kitware.com>2015-01-16 09:39:32 -0500
commitcdc29c36084ccfa447f171a25de2336b0bd74edd (patch)
treebc4b58fe32900739e3602f01d34503792f3346dc /CMakeLists.txt
parent2ece34516a6c4f99d27c42018b3548d0cb75e72e (diff)
downloadcmake-cdc29c36084ccfa447f171a25de2336b0bd74edd.tar.gz
Encoding: Switch to use UTF-8 internally by default on Windows.
This fixes several reported bugs about CMake not handling non-ascii paths on Windows. Practically, the use of some unicode characters may still be limited by the build or compiler tools. For example, a user may be limited by the build tools to using characters within the Windows ANSI code page (which can include non-ascii characters in the current system language).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1812b2773d..33d2ce6661 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,7 +45,7 @@ if(NOT DEFINED CMAKE_CXX_STANDARD)
endif()
# option to set the internal encoding of CMake to UTF-8
-option(CMAKE_ENCODING_UTF8 "Use UTF-8 encoding internally (experimental)." OFF)
+option(CMAKE_ENCODING_UTF8 "Use UTF-8 encoding internally." ON)
mark_as_advanced(CMAKE_ENCODING_UTF8)
if(CMAKE_ENCODING_UTF8)
set(KWSYS_ENCODING_DEFAULT_CODEPAGE CP_UTF8)