summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2016-08-26 08:57:40 -0400
committerBrad King <brad.king@kitware.com>2016-08-31 09:05:15 -0400
commit075cae5147bdca011841a9ebaf166636ab3e410f (patch)
tree98883283d9bf346cfe06991c7573bfe61dba4c8c /CMakeLists.txt
parent9a53af4068fd7f7627f8af193f551c1f2b5d4ac4 (diff)
downloadcmake-075cae5147bdca011841a9ebaf166636ab3e410f.tar.gz
Do not build libuv on SPARC
Some work may be needed to port to SPARC with Solaris and Linux.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9176049ad2..65876d5a26 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -484,6 +484,9 @@ int main(void) { return 0; }
elseif(CYGWIN)
# libuv does not support Cygwin
set(CMAKE_USE_LIBUV 0)
+ elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "sparc")
+ # Disable until it can be ported.
+ set(CMAKE_USE_LIBUV 0)
endif()
endif()
if(CMAKE_USE_LIBUV)