summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2017-05-08 10:26:48 -0400
committerBrad King <brad.king@kitware.com>2017-05-08 10:26:48 -0400
commit86edc5b6a5f9ef74d8807a6b90d209cce4e3a2d7 (patch)
tree7d621372296f5d87438cce7d1fa005bdc92b73a9 /CMakeLists.txt
parent7b2d529bdef9f6a5fa2bc3665a6b88cf52b110e1 (diff)
downloadcmake-86edc5b6a5f9ef74d8807a6b90d209cce4e3a2d7.tar.gz
Choose compiler-specific flags earlier in CMake's own build
Add the flags early enough be used in the checks for C++ features.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4dcf2f0095..6b88538bc2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -63,6 +63,10 @@ if(NOT DEFINED CMAKE_CXX_STANDARD AND NOT CMake_NO_CXX_STANDARD)
endif()
endif()
if(NOT CMake_TEST_EXTERNAL_CMAKE)
+ # include special compile flags for some compilers
+ include(CompileFlags.cmake)
+
+ # check for available C++ features
include(${CMake_SOURCE_DIR}/Source/Checks/cm_cxx_features.cmake)
endif()
@@ -648,9 +652,6 @@ if(NOT CMake_TEST_EXTERNAL_CMAKE)
include(${CMake_SOURCE_DIR}/Tests/CMakeInstall.cmake)
endif()
- # include special compile flags for some compilers
- include(CompileFlags.cmake)
-
# no clue why we are testing for this here
include(CheckSymbolExists)
CHECK_SYMBOL_EXISTS(unsetenv "stdlib.h" HAVE_UNSETENV)