summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2009-10-01 17:21:28 -0400
committerBill Hoffman <bill.hoffman@kitware.com>2009-10-01 17:21:28 -0400
commitf9687e328f7ea64ea6384aae11af36fdd3a12643 (patch)
tree91e2555b44011705d3188f11d7b7598f29c0ba7b /CMakeLists.txt
parent3c7354c1cd9fb081df8b3f4faef5160ea83f584f (diff)
downloadcmake-f9687e328f7ea64ea6384aae11af36fdd3a12643.tar.gz
Merge in changes to CMake-2-8 RC 2
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 17 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index eb41fea327..bdedb65082 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,3 +1,14 @@
+#=============================================================================
+# CMake - Cross Platform Makefile Generator
+# Copyright 2000-2009 Kitware, Inc., Insight Software Consortium
+#
+# Distributed under the OSI-approved BSD License (the "License");
+# see accompanying file Copyright.txt for details.
+#
+# This software is distributed WITHOUT ANY WARRANTY; without even the
+# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+# See the License for more information.
+#=============================================================================
CMAKE_MINIMUM_REQUIRED(VERSION 2.4.5 FATAL_ERROR)
PROJECT(CMake)
IF(COMMAND CMAKE_POLICY)
@@ -170,6 +181,7 @@ MACRO (CMAKE_BUILD_UTILITIES)
SET(KWSYS_USE_Process 1)
SET(KWSYS_USE_CommandLineArguments 1)
SET(KWSYS_HEADER_ROOT ${CMake_BINARY_DIR}/Source)
+ SET(KWSYS_INSTALL_DOC_DIR "${CMake_DOC_DEST}")
SUBDIRS(Source/kwsys)
#---------------------------------------------------------------------
@@ -303,7 +315,7 @@ ENDMACRO (CMAKE_BUILD_UTILITIES)
SET(CMake_VERSION_MAJOR 2)
SET(CMake_VERSION_MINOR 8)
SET(CMake_VERSION_PATCH 0)
-SET(CMake_VERSION_RC 1)
+SET(CMake_VERSION_RC 2)
# We use odd minor numbers for development versions.
# Use a date for the development patch level.
@@ -341,6 +353,7 @@ SET(CMAKE_MAN_DIR "/man" CACHE STRING
"Install location for man pages (relative to prefix).")
MARK_AS_ADVANCED(CMAKE_DATA_DIR CMAKE_DOC_DIR CMAKE_MAN_DIR)
STRING(REGEX REPLACE "^/" "" CMake_DATA_DEST "${CMAKE_DATA_DIR}")
+STRING(REGEX REPLACE "^/" "" CMake_DOC_DEST "${CMAKE_DOC_DIR}")
# include special compile flags for some compilers
INCLUDE(CompileFlags.cmake)
@@ -436,6 +449,9 @@ SUBDIRS(Tests)
ADD_TEST(SystemInformationNew "${CMAKE_CMAKE_COMMAND}"
--system-information -G "${CMAKE_TEST_GENERATOR}" )
+# Install license file as it requires.
+INSTALL(FILES Copyright.txt DESTINATION ${CMake_DOC_DEST})
+
# Install script directories.
INSTALL(
DIRECTORY Modules Templates