summaryrefslogtreecommitdiff
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2006-03-17 15:47:26 -0500
committerAndy Cedilnik <andy.cedilnik@kitware.com>2006-03-17 15:47:26 -0500
commit84f1420d82e725cae6ca3873c52473046e4debef (patch)
tree38076fd75e849543c800bd8679d0171f9cbbf3da /Source/CMakeLists.txt
parentb20cb780495630fa8088f9c95309597af22734c1 (diff)
downloadcmake-84f1420d82e725cae6ca3873c52473046e4debef.tar.gz
COMP: Use the current cmake's CheckCXXSourceCompiles
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index af259a59d5..a451e149b7 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -25,7 +25,7 @@ INCLUDE_DIRECTORIES(
ADD_DEFINITIONS(-DCMAKE_BUILD_WITH_CMAKE)
INCLUDE(CheckSymbolExists)
CHECK_SYMBOL_EXISTS(unsetenv "stdlib.h" HAVE_UNSETENV)
-INCLUDE("${CMAKE_ROOT}/Modules/CheckCXXSourceCompiles.cmake")
+INCLUDE("${CMAKE_SOURCE_DIR}/Modules/CheckCXXSourceCompiles.cmake")
CHECK_CXX_SOURCE_COMPILES(
"int main(int argc, char* argv[]) { return sizeof(environ); }"
HAVE_ENVIRON_WITHOUT_SIGNATURE)