summaryrefslogtreecommitdiff
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2006-02-19 15:25:27 -0500
committerBrad King <brad.king@kitware.com>2006-02-19 15:25:27 -0500
commit96f0266228d8fdf7d420c4a562e6988830fa4996 (patch)
tree2525ae96a1752df9f6024ee4f08c84c480bbe0a6 /Source/CMakeLists.txt
parent90c8ea1c03dea51c87fc75a38e018e5f9ce11546 (diff)
downloadcmake-96f0266228d8fdf7d420c4a562e6988830fa4996.tar.gz
ENH: Created new install script generation framework. The INSTALL command creates the generators which are later used by cmLocalGenerator to create the cmake_install.cmake files. A new target installation interface is provided by the INSTALL command which fixes several problems with the INSTALL_TARGETS command. See bug#2691. Bugs 1481 and 1695 are addressed by these changes.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index eebc4f33e4..b7c83e6930 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -115,6 +115,12 @@ SET(SRCS
cmGlobalGenerator.h
cmGlobalUnixMakefileGenerator3.cxx
cmGlobalUnixMakefileGenerator3.h
+ cmInstallGenerator.h
+ cmInstallGenerator.cxx
+ cmInstallScriptGenerator.h
+ cmInstallScriptGenerator.cxx
+ cmInstallTargetGenerator.h
+ cmInstallTargetGenerator.cxx
cmListFileCache.cxx
cmListFileCache.h
cmListFileLexer.c