summaryrefslogtreecommitdiff
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2006-04-13 11:00:52 -0400
committerBill Hoffman <bill.hoffman@kitware.com>2006-04-13 11:00:52 -0400
commitcae4e6b37a6ff7caf0748f2702fb503a9c95dcc8 (patch)
tree51115b16145313311c88cfd50409672c5f2b335e /Source/CMakeLists.txt
parentb323c3f51cc4caf7f8c26f86ba3dd4a08e964c4b (diff)
downloadcmake-cae4e6b37a6ff7caf0748f2702fb503a9c95dcc8.tar.gz
ENH: add patch for finding applications on OSX
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index e657f498de..ee346a3c06 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -220,6 +220,12 @@ IF(UNIX)
TARGET_LINK_LIBRARIES(CMakeLib ${CMAKE_DL_LIBS})
ENDIF(UNIX)
+# On Apple we need Carbon
+IF(APPLE)
+ FIND_LIBRARY(CARBON Carbon)
+ TARGET_LINK_LIBRARIES(CMakeLib ${CARBON})
+ENDIF(APPLE)
+
# On some platforms we need the rpcrt4 library for the VS 7 generators.
IF(CMAKE_BUILD_ON_VISUAL_STUDIO OR MINGW)
TARGET_LINK_LIBRARIES(CMakeLib rpcrt4)