summaryrefslogtreecommitdiff
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-10-03 17:28:00 -0400
committerBrad King <brad.king@kitware.com>2013-10-03 17:30:28 -0400
commitc04995b46eb93d39f97ee12ab63a5479c0b79b41 (patch)
tree11041fd33983392669cd2f57f9be46d92e791cad /Source/CMakeLists.txt
parente27523a834641fe4d9b8267db54f7c8837aca437 (diff)
downloadcmake-c04995b46eb93d39f97ee12ab63a5479c0b79b41.tar.gz
cmake: Split -E command implementation into separate source file
Move the cmake::ExecuteCMakeCommand static method and all the static methods it calls out of the 'cmake' class to a separate 'cmcmd' class. Build the latter as part of the main cmake executable with cmakemain.cxx and not in CMakeLib. Drop unused header includes from "cmake.cxx". By moving this implementation out of cmake.cxx we avoid carrying it around in all the executables that use class 'cmake'. It is needed only for the main "cmake -E" functionality.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 8412e3e86c..4144beadf7 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -545,7 +545,7 @@ if(APPLE)
endif()
# Build CMake executable
-add_executable(cmake cmakemain.cxx)
+add_executable(cmake cmakemain.cxx cmcmd.cxx cmcmd.h)
target_link_libraries(cmake CMakeLib)
# Build special executable for running programs on Windows 98.