summaryrefslogtreecommitdiff
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorCristian Adam <cristian.adam@gmail.com>2019-11-06 15:55:47 +0100
committerBrad King <brad.king@kitware.com>2019-11-06 10:07:01 -0500
commitf0c00bec1d7ce8f1209c4024e6000f907f11f1e9 (patch)
treeaf17fab1f71129b473457443e279cff01bd1edd3 /Source/CMakeLists.txt
parente0ec13059a04491c601e158c137cddc0802a410c (diff)
downloadcmake-f0c00bec1d7ce8f1209c4024e6000f907f11f1e9.tar.gz
CMakeVersion.rc: Fix build with llvm-rc
llvm-rc expects versioning as having four items, it fails otherwise.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 63e08de0f5..f4357e7721 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -1177,7 +1177,7 @@ if(WIN32)
unset(CMake_RCVERSION_MONTH_DAY)
unset(CMake_RCVERSION_YEAR)
else()
- set(CMake_RCVERSION ${CMake_VERSION_MAJOR},${CMake_VERSION_MINOR},${CMake_VERSION_PATCH})
+ set(CMake_RCVERSION ${CMake_VERSION_MAJOR},${CMake_VERSION_MINOR},${CMake_VERSION_PATCH},0)
endif()
set(CMake_RCVERSION_STR ${CMake_VERSION})