summaryrefslogtreecommitdiff
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorNicolas BUNEL <nbunel@purples-dev-thx11.1>2016-05-27 16:03:43 +0200
committerBrad King <brad.king@kitware.com>2016-06-01 11:12:36 -0400
commit18bfbc972fd3daf3e973f80072c4de09ec7e852b (patch)
tree092bba580eac1fcf3977a56adbdb2c3f18223f04 /Source/CMakeLists.txt
parentd6754d37d593a0189809dcf98bc4fdf3a609f0a3 (diff)
downloadcmake-18bfbc972fd3daf3e973f80072c4de09ec7e852b.tar.gz
Add option to control 'bin' directory of CMake's own installation (#16076)
Add a `CMAKE_BIN_DIR` cache entry to CMake's own build configuration. Add a `--bindir` option to the `bootstrap` script to set it.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 3223831f0f..3f00c8e29a 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -786,7 +786,7 @@ endif()
foreach(_tool ${_tools})
CMake_OPTIONAL_COMPONENT(${_tool})
- install(TARGETS ${_tool} DESTINATION bin ${COMPONENT})
+ install(TARGETS ${_tool} DESTINATION ${CMAKE_BIN_DIR} ${COMPONENT})
endforeach()
install(FILES cmCPluginAPI.h DESTINATION ${CMAKE_DATA_DIR}/include)