summaryrefslogtreecommitdiff
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorDāvis Mosāns <davispuh@gmail.com>2016-11-01 20:04:20 +0200
committerDāvis Mosāns <davispuh@gmail.com>2016-11-14 21:21:20 +0200
commit96103972ea1c478a2845fb68aee70a3395c148e0 (patch)
treef327e98f892d8e5cb8a45b1fbb250399f34149e3 /Source/CMakeLists.txt
parent92c865b8f5f0aef1af3ecd33692ce490467c0e70 (diff)
downloadcmake-96103972ea1c478a2845fb68aee70a3395c148e0.tar.gz
Add cmProcessOutput class to be used for decoding text data
This allows to decode text data we receive from external process which uses external encoding to our internal encoding.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 718b022466..fcda6f902c 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -330,6 +330,8 @@ set(SRCS
cmOrderDirectories.h
cmPolicies.h
cmPolicies.cxx
+ cmProcessOutput.cxx
+ cmProcessOutput.h
cmProcessTools.cxx
cmProcessTools.h
cmProperty.cxx
@@ -632,6 +634,9 @@ set(SRCS
cm_codecvt.cxx
)
+SET_PROPERTY(SOURCE cmProcessOutput.cxx APPEND PROPERTY COMPILE_DEFINITIONS
+ KWSYS_ENCODING_DEFAULT_CODEPAGE=${KWSYS_ENCODING_DEFAULT_CODEPAGE})
+
# Kdevelop only works on UNIX and not windows
if(UNIX)
set(SRCS ${SRCS} cmGlobalKdevelopGenerator.cxx)