summaryrefslogtreecommitdiff
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Turbov <i.zaufi@gmail.com>2022-08-21 09:13:32 +0400
committerBrad King <brad.king@kitware.com>2022-09-22 10:21:38 -0400
commit1f5d9c5299bb7add5a7afcc1d054fd4259c04b89 (patch)
tree5b39d5db7a842986a3a2514445f8925acd6bf59c /Source/CMakeLists.txt
parent9cdf5a67790ef78292366268af0a3de4b5cc3892 (diff)
downloadcmake-1f5d9c5299bb7add5a7afcc1d054fd4259c04b89.tar.gz
Build: Use imported target `LibArchive::LibArchive` instead of variables
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 93b3f0cda3..b1d8cb7f22 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -743,7 +743,6 @@ target_include_directories(
"${CMake_BINARY_DIR}/Source"
"${CMake_SOURCE_DIR}/Source"
"${CMake_SOURCE_DIR}/Source/LexerParser"
- ${CMAKE_TAR_INCLUDES}
${CMake_HAIKU_INCLUDE_DIRS}
)
target_link_libraries(
@@ -752,8 +751,8 @@ target_link_libraries(
cmstd
cmsys
EXPAT::EXPAT
+ LibArchive::LibArchive
ZLIB::ZLIB
- ${CMAKE_TAR_LIBRARIES}
${CMAKE_CURL_LIBRARIES}
${CMAKE_JSONCPP_LIBRARIES}
${CMAKE_LIBUV_LIBRARIES}