summaryrefslogtreecommitdiff
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2011-11-15 19:37:38 -0500
committerBrad King <brad.king@kitware.com>2011-11-16 10:14:53 -0500
commited7cef563445644684af47720c2f7c6fb0a2e440 (patch)
treeb18e93e7293b6592ef0f98c57a493eb8c4ca30c0 /Source/CMakeLists.txt
parenta9e686d68b5375c471c7204b818fdd2c0a547000 (diff)
downloadcmake-ed7cef563445644684af47720c2f7c6fb0a2e440.tar.gz
Factor Compute(File|String)MD5 into cmCryptoHash helper
Define an abstract API around the backend hash algorithm. Expose ifstream errors to HashFile callers. Always try opening the file. Succeed only if the end of file is reached without error.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index ba41d98c46..284c84dd15 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -129,6 +129,8 @@ SET(SRCS
cmComputeLinkInformation.h
cmComputeTargetDepends.h
cmComputeTargetDepends.cxx
+ cmCryptoHash.cxx
+ cmCryptoHash.h
cmCustomCommand.cxx
cmCustomCommand.h
cmCustomCommandGenerator.cxx