summaryrefslogtreecommitdiff
path: root/Source/QtDialog/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <ben.boeckel@kitware.com>2014-10-29 11:39:27 -0400
committerBen Boeckel <ben.boeckel@kitware.com>2014-10-29 11:47:29 -0400
commitfb13502fca5a344dd35be6fc919ae7e89ce9c6ea (patch)
treece33a472665826c0313a5662026bb4401622a93f /Source/QtDialog/CMakeLists.txt
parentfcb4541a05ea068715c8815c0294d2638721b071 (diff)
downloadcmake-fb13502fca5a344dd35be6fc919ae7e89ce9c6ea.tar.gz
QtDialog: install the 128x128 icon
Also only install the icons to the icons directory.
Diffstat (limited to 'Source/QtDialog/CMakeLists.txt')
-rw-r--r--Source/QtDialog/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/Source/QtDialog/CMakeLists.txt b/Source/QtDialog/CMakeLists.txt
index feedcc9d90..b59af94bda 100644
--- a/Source/QtDialog/CMakeLists.txt
+++ b/Source/QtDialog/CMakeLists.txt
@@ -172,10 +172,16 @@ set(CMAKE_INSTALL_DESTINATION_ARGS
install(TARGETS cmake-gui RUNTIME DESTINATION bin ${CMAKE_INSTALL_DESTINATION_ARGS})
if(UNIX AND NOT APPLE)
+ foreach (size IN ITEMS 32 128)
+ install(
+ FILES "${CMAKE_CURRENT_SOURCE_DIR}/CMakeSetup${size}.png"
+ DESTINATION "share/icons/hicolor/${size}x${size}/apps"
+ RENAME "CMakeSetup.png")
+ endforeach ()
+
# install a desktop file so CMake appears in the application start menu
# with an icon
install(FILES CMake.desktop DESTINATION share/applications )
- install(FILES CMakeSetup32.png DESTINATION share/pixmaps )
install(FILES cmakecache.xml DESTINATION share/mime/packages )
endif()