summaryrefslogtreecommitdiff
path: root/Tests/ArgumentExpansion/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <ben.boeckel@kitware.com>2010-10-08 09:46:38 -0400
committerBen Boeckel <ben.boeckel@kitware.com>2010-10-08 09:46:38 -0400
commit2507f937bd3f287e1905ef25ce2c37e616037671 (patch)
tree68086b9a73a9f57b16a2b8a47b72b5e544048176 /Tests/ArgumentExpansion/CMakeLists.txt
parentfe390a2607afcd8f0985a54990236a3ea16643ab (diff)
downloadcmake-2507f937bd3f287e1905ef25ce2c37e616037671.tar.gz
Change the failure case string to 'Unexpected'
VS6 detects the 'Error' string and fails itself even though we don't actually care about it unless CMAKE_STRICT is on.
Diffstat (limited to 'Tests/ArgumentExpansion/CMakeLists.txt')
-rw-r--r--Tests/ArgumentExpansion/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/Tests/ArgumentExpansion/CMakeLists.txt b/Tests/ArgumentExpansion/CMakeLists.txt
index bd781691b7..62017067ac 100644
--- a/Tests/ArgumentExpansion/CMakeLists.txt
+++ b/Tests/ArgumentExpansion/CMakeLists.txt
@@ -7,7 +7,7 @@ function (argument_tester expected expected_len)
list(LENGTH ${expected} expected_received_len)
if (NOT ${expected_received_len} EQUAL ${expected_len})
- message(STATUS "Error: Expanding expected values isn't working")
+ message(STATUS "Unexpected: Expanding expected values isn't working")
endif (NOT ${expected_received_len} EQUAL ${expected_len})
if (${argn_len} EQUAL ${expected_len})
@@ -17,7 +17,7 @@ function (argument_tester expected expected_len)
list(GET ${expected} ${i} expected_value)
if (NOT ${argn_value} STREQUAL ${expected_value})
- message(STATUS "Error: Argument ${i} doesn't match")
+ message(STATUS "Unexpected: Argument ${i} doesn't match")
message(STATUS " Expected: ${expected_value}")
message(STATUS " Received: ${argn_value}")
endif (NOT ${argn_value} STREQUAL ${expected_value})
@@ -25,7 +25,7 @@ function (argument_tester expected expected_len)
math(EXPR i "${i} + 1")
endwhile (i LESS ${argn_len})
else (${argn_len} EQUAL ${expected_len})
- message(STATUS "Error: Lengths of arguments don't match")
+ message(STATUS "Unexpected: Lengths of arguments don't match")
message(STATUS " Expected: ${expected_len}")
message(STATUS " Received: ${argn_len}")
endif (${argn_len} EQUAL ${expected_len})