summaryrefslogtreecommitdiff
path: root/Tests/CMakeLib/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Chevrier <marc.chevrier@gmail.com>2020-06-21 14:28:37 +0200
committerMarc Chevrier <marc.chevrier@gmail.com>2020-07-09 17:02:42 +0200
commitd654bf3449a24d412378af6c3aea53fa2899ad7d (patch)
tree7b5ac126f179e5513bbbc48fa03d3c598b02fec1 /Tests/CMakeLib/CMakeLists.txt
parente5798126fcfd08c7ca0f0f8d1fb627b04f655198 (diff)
downloadcmake-d654bf3449a24d412378af6c3aea53fa2899ad7d.tar.gz
STL Support: Add cm::filesystem::path in <cm/filesystem>
Diffstat (limited to 'Tests/CMakeLib/CMakeLists.txt')
-rw-r--r--Tests/CMakeLib/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/CMakeLib/CMakeLists.txt b/Tests/CMakeLib/CMakeLists.txt
index bb50d76f04..0b2c8f6c2a 100644
--- a/Tests/CMakeLib/CMakeLists.txt
+++ b/Tests/CMakeLib/CMakeLists.txt
@@ -29,6 +29,9 @@ set(CMakeLib_TESTS
testCMExtMemory.cxx
testCMExtAlgorithm.cxx
)
+if (CMake_TEST_FILESYSTEM_PATH OR NOT CMake_HAVE_CXX_FILESYSTEM)
+ list(APPEND CMakeLib_TESTS testCMFilesystemPath.cxx)
+endif()
add_executable(testUVProcessChainHelper testUVProcessChainHelper.cxx)