summaryrefslogtreecommitdiff
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2017-04-18 15:10:17 -0400
committerBrad King <brad.king@kitware.com>2017-04-18 15:10:17 -0400
commit2790ffc96f4e52017718bd1ce3fe1ef70ccae2d2 (patch)
treea6c970f66d0e1529168d070a3eca356a4b9a2d4a /Tests/CMakeLists.txt
parentf1e51ec3a5b3ed54dec054aa422fdd7a81b078b3 (diff)
downloadcmake-2790ffc96f4e52017718bd1ce3fe1ef70ccae2d2.tar.gz
Tests: Run CMakeTestAllGenerators serially
This test may take a long time because it runs many other tools. Do not make it compete with other tests for resources.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 910ff39b53..4269de1651 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1158,6 +1158,9 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
)
list(APPEND TEST_BUILD_DIRS
"${CMake_BINARY_DIR}/Tests/CMakeTestAllGenerators")
+ # This test runs a lot of processes. Do not make them compete
+ # for resources with other tests.
+ set_property(TEST CMakeTestAllGenerators PROPERTY RUN_SERIAL 1)
endif()
if(NOT DEFINED CTEST_RUN_CMakeTestMultipleConfigures)