summaryrefslogtreecommitdiff
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorFred Baksik <frodak17@gmail.com>2019-04-08 09:55:34 -0400
committerFred Baksik <frodak17@gmail.com>2019-04-11 13:15:50 -0400
commit5d2e1404bdfa83eeae5b361bd7d8a882aadc7242 (patch)
tree8aa8c0f88ed78d8fc15031587655c396813247b5 /Tests/CMakeLists.txt
parentb6bfa7eeb29937fbed44153518abfa4f28b9aa62 (diff)
downloadcmake-5d2e1404bdfa83eeae5b361bd7d8a882aadc7242.tar.gz
GHS: Update project layout to build targets correctly
-- Restructure projects and files to support proper building of targets Build order is determined by hierarchy of project files and folders Custom targets may have been run multiple times in the original file / folder structure -- Default to build targets that are part of ALL target -- List all known targets for this project Includes global targets for ALL_BUILD and INSTALL -- Compute build order for building targets
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 374696523a..2d9b80614b 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -2336,7 +2336,7 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
endmacro()
macro(add_test_GhsMulti_rename_install test_name)
add_test_GhsMulti( ${test_name} GhsMultiRenameInstall ${test_name}
- "-DCMAKE_INSTALL_PREFIX=. -DRUN_TEST=${test_name}" ${CMAKE_CMAKE_COMMAND} -P ./cmake_install.cmake)
+ "-DCMAKE_INSTALL_PREFIX=. -DRUN_TEST=${test_name}" ${CMAKE_CMAKE_COMMAND} --build . --target install)
endmacro()
#unset ghs config variables
unset(ghs_config_name)