summaryrefslogtreecommitdiff
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2021-06-03 10:40:56 -0400
committerBrad King <brad.king@kitware.com>2021-06-07 13:39:21 -0400
commit8f68bcad8fafddc82b73b69f21e122ece8603a8f (patch)
tree6989359100a0b17e3e293f17c9327e86e0790e92 /Tests/CMakeLists.txt
parentccc83ce1623a90c9354a940370ed8c06d2fea30b (diff)
downloadcmake-8f68bcad8fafddc82b73b69f21e122ece8603a8f.tar.gz
Tests: Add cases verifying flag ordering rules
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 38b4301444..331f6375f8 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -489,6 +489,11 @@ if(BUILD_TESTING)
if(CMAKE_Fortran_COMPILER)
set(CompileOptions_BUILD_OPTIONS -DTEST_FORTRAN=1)
endif()
+ if(_isMultiConfig)
+ set(CompileOptions_CTEST_OPTIONS --build-config $<CONFIGURATION>)
+ else()
+ set(CompileOptions_BUILD_OPTIONS -DCMAKE_BUILD_TYPE=$<CONFIGURATION>)
+ endif()
ADD_TEST_MACRO(CompileOptions CompileOptions)
ADD_TEST_MACRO(CompatibleInterface CompatibleInterface)
ADD_TEST_MACRO(AliasTarget AliasTarget)