summaryrefslogtreecommitdiff
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2021-01-15 09:19:43 -0500
committerBrad King <brad.king@kitware.com>2021-01-15 09:27:17 -0500
commitc6845f9495e0411cf86966aa726ba362b693a8d1 (patch)
treee1c8d4d7c1d61282d759e53adcb81ba221f958ee /Tests/CMakeLists.txt
parent50b8dc8735e836658755e6dc3dc2a9f00e1006e1 (diff)
downloadcmake-c6845f9495e0411cf86966aa726ba362b693a8d1.tar.gz
Tests: Remove outdated CMakeTestMultipleConfigures test
In practice this test has not helped us find any problems AFAIK. Tests like RunCMake.BuildDepends and other RunCMake tests cover much of what this test was meant to do. Since CMakeTestMultipleConfigures takes a long time to run on some generator/platform combinations, it is not worth what it covers. Remove the test.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt15
1 files changed, 0 insertions, 15 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 74fca5c666..5948911298 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1279,21 +1279,6 @@ if(BUILD_TESTING)
set_property(TEST CMakeTestAllGenerators PROPERTY RUN_SERIAL 1)
endif()
- if(NOT DEFINED CTEST_RUN_CMakeTestMultipleConfigures)
- set(CTEST_RUN_CMakeTestMultipleConfigures ON)
- endif()
-
- if(CTEST_RUN_CMakeTestMultipleConfigures)
- add_test(CMakeTestMultipleConfigures ${CMAKE_CMAKE_COMMAND}
- -D dir=${CMake_BINARY_DIR}/Tests/CMakeTestMultipleConfigures
- -D gen=${CMAKE_GENERATOR}
- -D CMake_SOURCE_DIR=${CMake_SOURCE_DIR}
- -P ${CMake_SOURCE_DIR}/Tests/CMakeTestMultipleConfigures/RunCMake.cmake
- )
- list(APPEND TEST_BUILD_DIRS
- "${CMake_BINARY_DIR}/Tests/CMakeTestMultipleConfigures")
- endif()
-
if(NOT CMake_TEST_EXTERNAL_CMAKE)
add_test(LoadedCommandOneConfig ${CMAKE_CTEST_COMMAND}
--build-and-test