summaryrefslogtreecommitdiff
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2012-09-29 06:36:46 -0400
committerBrad King <brad.king@kitware.com>2012-09-29 07:17:42 -0400
commit2ccca05fade0014dbfbce906b20ab4073ecd8d9c (patch)
treeb775cae8af5cd59e37710152ac719f90e8bd19a7 /Tests/CMakeLists.txt
parentefc83b369b26624e7f0fb90d9125ef5ec6d1f7fa (diff)
downloadcmake-2ccca05fade0014dbfbce906b20ab4073ecd8d9c.tar.gz
Run PDBDirectoryAndName test on MSVC and Intel
Move it out of the condition that also accepts MinGW/MSYS. Teach the test to allow the Intel for Windows compiler but do not verify the results because the compiler does not seem to write PDB output in all cases.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 4d071cb6c2..ae69ce86b5 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1254,12 +1254,12 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
if(CMAKE_TEST_MSVC)
ADD_TEST_MACRO(ForceInclude foo)
+ ADD_TEST_MACRO(PDBDirectoryAndName myexe)
ADD_TEST_MACRO(PrecompiledHeader foo)
endif()
if(CMAKE_TEST_MSVC OR
"${CMAKE_TEST_GENERATOR}" MATCHES "(MSYS|MinGW) Makefiles")
ADD_TEST_MACRO(ModuleDefinition example_exe)
- ADD_TEST_MACRO(PDBDirectoryAndName myexe)
endif()
ADD_TEST_MACRO(CheckCompilerRelatedVariables CheckCompilerRelatedVariables)