summaryrefslogtreecommitdiff
path: root/Tests/CTestTestLaunchers/launcher_test_project/CMakeLists.txt
diff options
context:
space:
mode:
authorNils Gladitz <nilsgladitz@gmail.com>2013-10-29 22:29:27 +0100
committerBrad King <brad.king@kitware.com>2013-10-31 09:29:55 -0400
commit4fcb97eaac5de1cdd4adc86ac757ce68b37c9858 (patch)
tree2d83816069cb75ff469eea71f5db8f1cc4966051 /Tests/CTestTestLaunchers/launcher_test_project/CMakeLists.txt
parent05c70424f6fb3aac890f50aec067b60e997113b1 (diff)
downloadcmake-4fcb97eaac5de1cdd4adc86ac757ce68b37c9858.tar.gz
Tests: Add test for CTEST_USE_LAUNCHERS capture of custom commands
This new test detects if custom command failures are detected with launchers.
Diffstat (limited to 'Tests/CTestTestLaunchers/launcher_test_project/CMakeLists.txt')
-rw-r--r--Tests/CTestTestLaunchers/launcher_test_project/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/Tests/CTestTestLaunchers/launcher_test_project/CMakeLists.txt b/Tests/CTestTestLaunchers/launcher_test_project/CMakeLists.txt
new file mode 100644
index 0000000000..06c57253df
--- /dev/null
+++ b/Tests/CTestTestLaunchers/launcher_test_project/CMakeLists.txt
@@ -0,0 +1,19 @@
+cmake_minimum_required(VERSION 2.8.12)
+
+project(launcher_test_project)
+
+include(CTest)
+
+add_custom_command(
+ OUTPUT test1.txt
+ COMMAND ${CMAKE_COMMAND}
+ ARGS -DTESTID=1 -P "${CMAKE_CURRENT_SOURCE_DIR}/command.cmake"
+)
+
+add_custom_command(
+ OUTPUT test2.txt
+ COMMAND ${CMAKE_COMMAND}
+ ARGS -DTESTID=2 -P "${CMAKE_CURRENT_SOURCE_DIR}/command.cmake"
+)
+
+add_custom_target(mytarget ALL DEPENDS test1.txt test2.txt)