summaryrefslogtreecommitdiff
path: root/Tests/ComplexOneConfig/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2003-08-07 16:54:45 -0400
committerBill Hoffman <bill.hoffman@kitware.com>2003-08-07 16:54:45 -0400
commit5523c4a967787b0fdc715e886eb3513e498baa41 (patch)
tree7d79d2fec47d54af46d698723b733f7d2dd40dd6 /Tests/ComplexOneConfig/CMakeLists.txt
parentab335dbc9b7378154b7e60f0eb82c5a7d13d1fa8 (diff)
downloadcmake-5523c4a967787b0fdc715e886eb3513e498baa41.tar.gz
BUG: fix the test
Diffstat (limited to 'Tests/ComplexOneConfig/CMakeLists.txt')
-rw-r--r--Tests/ComplexOneConfig/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/Tests/ComplexOneConfig/CMakeLists.txt b/Tests/ComplexOneConfig/CMakeLists.txt
index aa376e5586..2aaa407faf 100644
--- a/Tests/ComplexOneConfig/CMakeLists.txt
+++ b/Tests/ComplexOneConfig/CMakeLists.txt
@@ -49,12 +49,12 @@ LOAD_CACHE(${Complex_SOURCE_DIR}/Cache
INCLUDE_INTERNALS
CACHE_TEST_VAR_INTERNAL)
-LOAD_CACHE(${Complex_BINARY_DIR} READ_WITH_PREFIX foo CACHE_TEST_VAR_INTERNAL)
-IF(${fooCACHE_TEST_VAR_INTERNAL} MATCHES bar)
- MESSAGE("Load cache worked")
-ELSE(${fooCACHE_TEST_VAR_INTERNAL} MATCHES bar)
- MESSAGE(FATAL_ERROR "Load cache with prefix failed")
-ENDIF(${fooCACHE_TEST_VAR_INTERNAL} MATCHES bar)
+LOAD_CACHE(${Complex_SOURCE_DIR}/Cache READ_WITH_PREFIX foo CACHE_TEST_VAR2)
+IF(${fooCACHE_TEST_VAR2} MATCHES bar)
+ MESSAGE("Load cache worked: ${fooCACHE_TEST_VAR2}")
+ELSE(${fooCACHE_TEST_VAR2} MATCHES bar)
+ MESSAGE(FATAL_ERROR "Load cache with prefix failed: ${fooCACHE_TEST_VAR2}")
+ENDIF(${fooCACHE_TEST_VAR2} MATCHES bar)