summaryrefslogtreecommitdiff
path: root/Tests/CustomCommand/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2008-06-04 12:10:59 -0400
committerBrad King <brad.king@kitware.com>2008-06-04 12:10:59 -0400
commit306e3e573fe409c0818fa069fd7e625c19713ed9 (patch)
tree3ae92cbbe3ec500a83632d45259e4a47018b134b /Tests/CustomCommand/CMakeLists.txt
parent7fc72e6471f641a9c08fe85c2c7d24eda75d10db (diff)
downloadcmake-306e3e573fe409c0818fa069fd7e625c19713ed9.tar.gz
ENH: Add test for make variable replacement in a custom command with the VERBATIM option.
Diffstat (limited to 'Tests/CustomCommand/CMakeLists.txt')
-rw-r--r--Tests/CustomCommand/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/CustomCommand/CMakeLists.txt b/Tests/CustomCommand/CMakeLists.txt
index 7e9f29c046..5d785bc3d5 100644
--- a/Tests/CustomCommand/CMakeLists.txt
+++ b/Tests/CustomCommand/CMakeLists.txt
@@ -42,6 +42,8 @@ ADD_CUSTOM_COMMAND(
MAIN_DEPENDENCY ${PROJECT_SOURCE_DIR}/wrapped.h
COMMAND ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/wrapper
${PROJECT_BINARY_DIR}/wrapped.c ${PROJECT_BINARY_DIR}/wrapped_help.c
+ ${CMAKE_CFG_INTDIR} # this argument tests passing of the configuration
+ VERBATIM # passing of configuration should work in this mode
)
################################################################