summaryrefslogtreecommitdiff
path: root/Tests/FindLAPACK/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2021-07-12 11:08:35 -0400
committerBrad King <brad.king@kitware.com>2021-07-12 11:11:37 -0400
commit31ac4b916525126c5d7f3a944a749b8989a456c5 (patch)
tree600a369af23eab5cbcb8207378e0998356dffb88 /Tests/FindLAPACK/CMakeLists.txt
parent57dcde19da24d211bad945fbbe7851abbf9bdab3 (diff)
downloadcmake-31ac4b916525126c5d7f3a944a749b8989a456c5.tar.gz
ci: Verify that Intel MKL is found when it is the only BLAS/LAPACK
Issue: #22403
Diffstat (limited to 'Tests/FindLAPACK/CMakeLists.txt')
-rw-r--r--Tests/FindLAPACK/CMakeLists.txt14
1 files changed, 12 insertions, 2 deletions
diff --git a/Tests/FindLAPACK/CMakeLists.txt b/Tests/FindLAPACK/CMakeLists.txt
index 26cfa87629..535c7b60e2 100644
--- a/Tests/FindLAPACK/CMakeLists.txt
+++ b/Tests/FindLAPACK/CMakeLists.txt
@@ -6,6 +6,11 @@ foreach(variant IN LISTS CMake_TEST_FindLAPACK)
set(vendor "${variant}")
set(alt_compiler "")
endif()
+ if(vendor STREQUAL "All" AND CMake_TEST_FindLAPACK_All)
+ set(EXPECT_All "-DEXPECT_All=${CMake_TEST_FindLAPACK_All}")
+ else()
+ set(EXPECT_All "")
+ endif()
add_test(NAME FindLAPACK.Test_${variant} COMMAND
${CMAKE_CTEST_COMMAND} -C $<CONFIGURATION>
--build-and-test
@@ -13,7 +18,7 @@ foreach(variant IN LISTS CMake_TEST_FindLAPACK)
"${CMake_BINARY_DIR}/Tests/FindLAPACK/Test_${variant}"
${build_generator_args}
--build-project TestFindLAPACK
- --build-options ${build_options} ${alt_compiler} -DBLA_VENDOR=${vendor}
+ --build-options ${build_options} ${alt_compiler} ${EXPECT_All} -DBLA_VENDOR=${vendor}
--test-command ${CMAKE_CTEST_COMMAND} -V -C $<CONFIGURATION>
)
endforeach()
@@ -26,6 +31,11 @@ foreach(variant IN LISTS CMake_TEST_FindLAPACK_STATIC)
set(vendor "${variant}")
set(alt_compiler "")
endif()
+ if(vendor STREQUAL "All" AND CMake_TEST_FindLAPACK_STATIC_All)
+ set(EXPECT_All "-DEXPECT_All=${CMake_TEST_FindLAPACK_STATIC_All}")
+ else()
+ set(EXPECT_All "")
+ endif()
add_test(NAME FindLAPACK.Test_${variant}_Static COMMAND
${CMAKE_CTEST_COMMAND} -C $<CONFIGURATION>
--build-and-test
@@ -33,7 +43,7 @@ foreach(variant IN LISTS CMake_TEST_FindLAPACK_STATIC)
"${CMake_BINARY_DIR}/Tests/FindLAPACK/Test_${variant}_Static"
${build_generator_args}
--build-project TestFindLAPACK
- --build-options ${build_options} ${alt_compiler} -DBLA_VENDOR=${vendor} -DBLA_STATIC=ON
+ --build-options ${build_options} ${alt_compiler} ${EXPECT_All} -DBLA_VENDOR=${vendor} -DBLA_STATIC=ON
--test-command ${CMAKE_CTEST_COMMAND} -V -C $<CONFIGURATION>
)
endforeach()