summaryrefslogtreecommitdiff
path: root/Tests/OutOfSource/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2006-10-16 15:18:03 -0400
committerBrad King <brad.king@kitware.com>2006-10-16 15:18:03 -0400
commit30235517f81ed7ef8ff8e58685e786da472bf0d6 (patch)
treec8c2162c4b697b476e2de36b4153d22fbfe0d274 /Tests/OutOfSource/CMakeLists.txt
parent49bf0b9e3d48dd650daa924a238fccc1bc3324d7 (diff)
downloadcmake-30235517f81ed7ef8ff8e58685e786da472bf0d6.tar.gz
BUG: Need to collapse path argument to get_directory_property. This addresses bug#3847.
Diffstat (limited to 'Tests/OutOfSource/CMakeLists.txt')
-rw-r--r--Tests/OutOfSource/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/OutOfSource/CMakeLists.txt b/Tests/OutOfSource/CMakeLists.txt
index a053f14018..265d47deb4 100644
--- a/Tests/OutOfSource/CMakeLists.txt
+++ b/Tests/OutOfSource/CMakeLists.txt
@@ -4,6 +4,10 @@ project (OutOfSource)
add_subdirectory(SubDir)
get_directory_property(ANIMAL DIRECTORY OutOfSourceSubdir DEFINITION WEASELS)
+get_directory_property(ANIMALREL DIRECTORY SubDir/../OutOfSourceSubdir DEFINITION WEASELS)
+IF(NOT "${ANIMAL}" STREQUAL "${ANIMALREL}")
+ MESSAGE(FATAL_ERROR "GET_DIRECTORY_PROPERTY does not seem to collapse paths.")
+ENDIF(NOT "${ANIMAL}" STREQUAL "${ANIMALREL}")
configure_file(
${OutOfSource_SOURCE_DIR}/testdp.h.in