summaryrefslogtreecommitdiff
path: root/Tests/SimpleInstallS2/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2006-08-10 09:38:52 -0400
committerBill Hoffman <bill.hoffman@kitware.com>2006-08-10 09:38:52 -0400
commit4ddcdbed9a0a0ed140ef4a2888acbb47da4e3361 (patch)
treeca01119a0bcdb015fd351109c77b7355a4c75084 /Tests/SimpleInstallS2/CMakeLists.txt
parent9419e6996108967a05da55cbe5c3f61196f6f07d (diff)
downloadcmake-4ddcdbed9a0a0ed140ef4a2888acbb47da4e3361.tar.gz
ENH: fix failing tests
Diffstat (limited to 'Tests/SimpleInstallS2/CMakeLists.txt')
-rw-r--r--Tests/SimpleInstallS2/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/Tests/SimpleInstallS2/CMakeLists.txt b/Tests/SimpleInstallS2/CMakeLists.txt
index eb8a97fea4..05808a356d 100644
--- a/Tests/SimpleInstallS2/CMakeLists.txt
+++ b/Tests/SimpleInstallS2/CMakeLists.txt
@@ -187,11 +187,18 @@ IF(UNIX AND NOT APPLE)
ENDIF(NOT file_command)
EXECUTE_PROCESS(COMMAND ${file_command} ${found_compress}
OUTPUT_VARIABLE output)
- if(NOT "${output}" MATCHES "script")
+ set(SKIP_TZ FALSE)
+ if("${output}" MATCHES "script")
+ set(SKIP_TZ TRUE)
+ endif("${output}" MATCHES "script")
+ if("${output}" MATCHES "dummy.sh")
+ set(SKIP_TZ TRUE)
+ endif("${output}" MATCHES "dummy.sh")
+ if(NOT SKIP_TZ)
message("compress found and it was not a script")
message("output from file command: [${output}]")
SET(CPACK_GENERATOR "${CPACK_GENERATOR};TZ")
- else(NOT "${output}" MATCHES "script")
+ else(NOT SKIP_TZ)
message("compress found, but it was a script so dont use it")
message("output from file command: [${output}]")
endif(NOT "${output}" MATCHES "script")