summaryrefslogtreecommitdiff
path: root/Tests/SimpleInstallS2/CMakeLists.txt
diff options
context:
space:
mode:
authorRolf Eike Beer <eike@sf-mail.de>2013-06-02 21:42:10 +0200
committerRolf Eike Beer <eike@sf-mail.de>2013-06-02 22:18:19 +0200
commitcd4451d1e738a729a1a8d0ed34b544cada1de078 (patch)
tree099468fd2b338fd193ccf9dd5c1701245d3e1a1f /Tests/SimpleInstallS2/CMakeLists.txt
parenta4d8c64d10105fd4448ffde6a5d2fb74c1bb4f57 (diff)
downloadcmake-cd4451d1e738a729a1a8d0ed34b544cada1de078.tar.gz
replace string(... MATCHES "^const$) with string(... STREQUAL "const")
Diffstat (limited to 'Tests/SimpleInstallS2/CMakeLists.txt')
-rw-r--r--Tests/SimpleInstallS2/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/SimpleInstallS2/CMakeLists.txt b/Tests/SimpleInstallS2/CMakeLists.txt
index 479d6ec367..b969bfdf07 100644
--- a/Tests/SimpleInstallS2/CMakeLists.txt
+++ b/Tests/SimpleInstallS2/CMakeLists.txt
@@ -122,7 +122,7 @@ if(STAGE2)
RESULT_VARIABLE SAMPLE_SCRIPT_RESULT
OUTPUT_VARIABLE SAMPLE_SCRIPT_OUTPUT
)
- if(NOT "${SAMPLE_SCRIPT_RESULT}" MATCHES "^0$")
+ if(NOT "${SAMPLE_SCRIPT_RESULT}" STREQUAL "0")
message(FATAL_ERROR
"Sample script [${CUR_SCRIPT}] failed: [${SAMPLE_SCRIPT_RESULT}]")
endif()