summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2001-08-24 17:00:40 -0400
committerBill Hoffman <bill.hoffman@kitware.com>2001-08-24 17:00:40 -0400
commit03b77686b12b041d4ccb5e3cbc5d7fd12ee32649 (patch)
treed02cfdc672ba23d679e12b9ef62f4a83bdae82b5 /configure.in
parented6e3e88e0183e3ee2e4a9d3937f1d5b6b313749 (diff)
downloadcmake-03b77686b12b041d4ccb5e3cbc5d7fd12ee32649.tar.gz
auto detect lang:std:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5310fb9c9b..823a27bca1 100644
--- a/configure.in
+++ b/configure.in
@@ -16,6 +16,30 @@ fullSrcDir=`cd $srcdir; pwd`
CMAKE_ROOT_DIR=$fullSrcDir
AC_SUBST(CMAKE_ROOT_DIR)
+
+# Step 1: set the variable "system" to hold the name and version number
+# for the system. This can usually be done via the "uname" command, but
+# there are a few systems, like Next, where this doesn't work.
+
+AC_MSG_CHECKING([system version (for dynamic loading)])
+if test -f /usr/lib/NextStep/software_version; then
+ system=NEXTSTEP-`awk '/3/,/3/' /usr/lib/NextStep/software_version`
+else
+ system=`uname -s`-`uname -r`
+ if test "$?" -ne 0 ; then
+ AC_MSG_RESULT([unknown (can't find uname command)])
+ system=unknown
+ else
+ # Special check for weird MP-RAS system (uname returns weird
+ # results, and the version is kept in special file).
+
+ if test -r /etc/.relid -a "X`uname -n`" = "X`uname -s`" ; then
+ system=MP-RAS-`awk '{print $3}' /etc/.relid'`
+ fi
+ AC_MSG_RESULT($system)
+ fi
+fi
+
CMAKE_ANSI_CFLAGS=""
# on hp use -Aa for ansi
if test $ac_cv_prog_gxx = no; then