summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2001-05-22 13:40:49 -0400
committerBill Hoffman <bill.hoffman@kitware.com>2001-05-22 13:40:49 -0400
commitb5b4c0eb5ce272d82695c5c50383c3084fe6e2d6 (patch)
treef9178ba322865cfd40693457f72e4132721f056e /configure.in
parentbeaa7dc1c84a58063f72c54559ecf0b2b45de45c (diff)
downloadcmake-b5b4c0eb5ce272d82695c5c50383c3084fe6e2d6.tar.gz
use cxxflags in test builds
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index a3a5ee2c28..9312a5fa83 100644
--- a/configure.in
+++ b/configure.in
@@ -68,7 +68,7 @@ if test $ac_cv_prog_gxx = no; then
cat > conftest.cc <<!
#include <iostream>
!
- if test -z "`${CXX} -c conftest.cc 2>&1`"; then
+ if test -z "`${CXX} $CXXFLAGS $CPPFLAGS -c conftest.cc 2>&1`"; then
echo "$ac_t""yes" 1>&6
else
AC_DEFINE(CMAKE_NO_ANSI_STREAM_HEADERS)
@@ -78,14 +78,13 @@ fi
# check to see if stl is in the std namespace
if test $ac_cv_prog_gxx = no; then
- echo "******"
AC_MSG_CHECKING( ansi standard namespace support )
rm -rf conftest.*
cat > conftest.cc <<!
#include <list>
void foo() { std::list<int> l; }
!
- if test -z "`${CXX} -c conftest.cc 2>&1`"; then
+ if test -z "`${CXX} $CXXFLAGS $CPPFLAGS -c conftest.cc 2>&1`"; then
echo "$ac_t""yes" 1>&6
else
AC_DEFINE(CMAKE_NO_STD_NAMESPACE)