summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 0 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a4f533d993..2b9eb2d569 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -60,17 +60,6 @@ else()
set(USE_LGPL "")
endif()
-if("${CMake_SOURCE_DIR}" STREQUAL "${CMAKE_SOURCE_DIR}")
- # Disallow architecture-specific try_run. It may not run on the host.
- macro(TRY_RUN)
- if(CMAKE_TRY_COMPILE_OSX_ARCHITECTURES)
- message(FATAL_ERROR "TRY_RUN not allowed with CMAKE_TRY_COMPILE_OSX_ARCHITECTURES=[${CMAKE_TRY_COMPILE_OSX_ARCHITECTURES}]")
- else()
- _TRY_RUN(${ARGV})
- endif()
- endmacro()
-endif()
-
# Use most-recent available language dialects with GNU and Clang
if(NOT DEFINED CMAKE_C_STANDARD AND NOT CMake_NO_C_STANDARD)
include(${CMake_SOURCE_DIR}/Source/Checks/cm_c11_thread_local.cmake)