summaryrefslogtreecommitdiff
path: root/Tests/MakeClean/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/MakeClean/CMakeLists.txt')
-rw-r--r--Tests/MakeClean/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/Tests/MakeClean/CMakeLists.txt b/Tests/MakeClean/CMakeLists.txt
index 74007542cf..13348a28b9 100644
--- a/Tests/MakeClean/CMakeLists.txt
+++ b/Tests/MakeClean/CMakeLists.txt
@@ -13,12 +13,12 @@ if(TOCLEAN_BUILT)
"Building ToClean succeeded with the following output:\n"
"[${OUTPUT}]"
)
-else(TOCLEAN_BUILT)
+else()
message(FATAL_ERROR
"Building ToClean failed with the following output:\n"
"[${OUTPUT}]"
)
-endif(TOCLEAN_BUILT)
+endif()
# Get the set of files to check from the ToClean project.
include(${MakeClean_BINARY_DIR}/ToClean/ToCleanFiles.cmake)
@@ -26,16 +26,16 @@ include(${MakeClean_BINARY_DIR}/ToClean/ToCleanFiles.cmake)
# Check for the existence of the files.
foreach(f ${TOCLEAN_FILES})
if(EXISTS "${f}")
- else(EXISTS "${f}")
+ else()
message(FATAL_ERROR "File \"${f}\" does not exist!")
- endif(EXISTS "${f}")
-endforeach(f)
+ endif()
+endforeach()
# Configure an executable to check that all the files are missing.
set(CHECK_FILES)
foreach(f ${TOCLEAN_FILES})
set(CHECK_FILES "${CHECK_FILES} \"${f}\",\n")
-endforeach(f)
+endforeach()
configure_file(${MakeClean_SOURCE_DIR}/check_clean.c.in
${MakeClean_BINARY_DIR}/check_clean.c @ONLY IMMEDIATE)
add_executable(check_clean ${MakeClean_BINARY_DIR}/check_clean.c)