summaryrefslogtreecommitdiff
path: root/Tests/OutOfSource/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/OutOfSource/CMakeLists.txt')
-rw-r--r--Tests/OutOfSource/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/OutOfSource/CMakeLists.txt b/Tests/OutOfSource/CMakeLists.txt
index a053f14018..265d47deb4 100644
--- a/Tests/OutOfSource/CMakeLists.txt
+++ b/Tests/OutOfSource/CMakeLists.txt
@@ -4,6 +4,10 @@ project (OutOfSource)
add_subdirectory(SubDir)
get_directory_property(ANIMAL DIRECTORY OutOfSourceSubdir DEFINITION WEASELS)
+get_directory_property(ANIMALREL DIRECTORY SubDir/../OutOfSourceSubdir DEFINITION WEASELS)
+IF(NOT "${ANIMAL}" STREQUAL "${ANIMALREL}")
+ MESSAGE(FATAL_ERROR "GET_DIRECTORY_PROPERTY does not seem to collapse paths.")
+ENDIF(NOT "${ANIMAL}" STREQUAL "${ANIMALREL}")
configure_file(
${OutOfSource_SOURCE_DIR}/testdp.h.in