summaryrefslogtreecommitdiff
path: root/Tests/PDBDirectoryAndName/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/PDBDirectoryAndName/CMakeLists.txt')
-rw-r--r--Tests/PDBDirectoryAndName/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/Tests/PDBDirectoryAndName/CMakeLists.txt b/Tests/PDBDirectoryAndName/CMakeLists.txt
index 865d27872f..bc2f01317b 100644
--- a/Tests/PDBDirectoryAndName/CMakeLists.txt
+++ b/Tests/PDBDirectoryAndName/CMakeLists.txt
@@ -1,8 +1,9 @@
cmake_minimum_required(VERSION 2.8)
project(PDBDirectoryAndName C)
-if(NOT MSVC)
- MESSAGE(FATAL_ERROR "The PDB file test works only with MSVC")
+# Make sure the proper compiler is in use.
+if(NOT MSVC AND NOT "${CMAKE_C_COMPILER_ID}" MATCHES "^(Intel)$")
+ message(FATAL_ERROR "The PDBDirectoryAndName test works only with MSVC or Intel")
endif()
set(my_targets "")
@@ -57,6 +58,10 @@ target_link_libraries(myexe2 mylibA mylibD)
if("${CMAKE_GENERATOR}" MATCHES "Visual Studio 6")
return()
endif()
+# PDB output not fully implemented for Intel
+if("${CMAKE_C_COMPILER_ID}" MATCHES "^(Intel)$")
+ return()
+endif()
set(pdbs "")
foreach(t ${my_targets})