summaryrefslogtreecommitdiff
path: root/Tests/PositionIndependentTargets/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/PositionIndependentTargets/CMakeLists.txt')
-rw-r--r--Tests/PositionIndependentTargets/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/Tests/PositionIndependentTargets/CMakeLists.txt b/Tests/PositionIndependentTargets/CMakeLists.txt
new file mode 100644
index 0000000000..e79f3b74b7
--- /dev/null
+++ b/Tests/PositionIndependentTargets/CMakeLists.txt
@@ -0,0 +1,14 @@
+
+cmake_minimum_required(VERSION 2.8)
+
+project(PositionIndependentTargets)
+
+include(CheckCXXSourceCompiles)
+
+include_directories("${CMAKE_CURRENT_SOURCE_DIR}") # For pic_test.h
+
+add_subdirectory(global)
+add_subdirectory(targets)
+add_subdirectory(interface)
+
+add_executable(PositionIndependentTargets main.cpp)