summaryrefslogtreecommitdiff
path: root/Tests/TarTest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Tests/TarTest/CMakeLists.txt')
-rw-r--r--Tests/TarTest/CMakeLists.txt18
1 files changed, 9 insertions, 9 deletions
diff --git a/Tests/TarTest/CMakeLists.txt b/Tests/TarTest/CMakeLists.txt
index b1f1c6dc30..bcc340bb3f 100644
--- a/Tests/TarTest/CMakeLists.txt
+++ b/Tests/TarTest/CMakeLists.txt
@@ -6,15 +6,15 @@ macro(EXEC_TAR_COMMAND DIR ARGS)
exec_program("${CMAKE_COMMAND}" "${DIR}" ARGS "-E tar ${ARGS}" RETURN_VALUE RET)
if(${RET})
message(FATAL_ERROR "CMake tar command failed with arguments \"${ARGS}\"")
- endif(${RET})
-endmacro(EXEC_TAR_COMMAND)
+ endif()
+endmacro()
# Create a directory structure
set(CHECK_FILES)
macro(COPY F1 F2)
configure_file("${CMAKE_CURRENT_SOURCE_DIR}/${F1}" "${CMAKE_CURRENT_BINARY_DIR}/tar_dir/${F2}" COPYONLY)
set(CHECK_FILES ${CHECK_FILES} "${F2}")
-endmacro(COPY)
+endmacro()
COPY("CMakeLists.txt" "f1.txt")
COPY("CMakeLists.txt" "d1/f1.txt")
COPY("CMakeLists.txt" "d 2/f1.txt")
@@ -26,7 +26,7 @@ COPY("CMakeLists.txt" "My Special Directory/f1.txt")
if(UNIX)
exec_program("ln" ARGS "-sf f1.txt \"${CMAKE_CURRENT_BINARY_DIR}/tar_dir/d1/f2.txt\"")
set(CHECK_FILES ${CHECK_FILES} "d1/f2.txt")
-endif(UNIX)
+endif()
# cleanup first in case there are files left from previous runs
# if the umask is odd on the machine it might create files that
@@ -54,14 +54,14 @@ macro(CHECK_DIR_STRUCTURE DIR)
set(rfile "${CMAKE_CURRENT_BINARY_DIR}/tar_dir/${file}")
if(NOT EXISTS "${sfile}")
message(SEND_ERROR "Cannot find file ${sfile}")
- else(NOT EXISTS "${sfile}")
+ else()
exec_program("${CMAKE_COMMAND}" ARGS "-E compare_files \"${sfile}\" \"${rfile}\"" RETURN_VALUE ret)
if(${ret})
message(SEND_ERROR "Files \"${sfile}\" \"${rfile}\" are different")
- endif(${ret})
- endif(NOT EXISTS "${sfile}")
- endforeach(file)
-endmacro(CHECK_DIR_STRUCTURE)
+ endif()
+ endif()
+ endforeach()
+endmacro()
CHECK_DIR_STRUCTURE("${CMAKE_CURRENT_BINARY_DIR}/test_output_tar/tar_dir")