summaryrefslogtreecommitdiff
path: root/colm/Makefile.am
diff options
context:
space:
mode:
authorAdrian Thurston <thurston@complang.org>2012-07-01 12:23:00 -0400
committerAdrian Thurston <thurston@complang.org>2012-07-01 12:23:00 -0400
commitd8cdec468bb7efad768d25872147533312cffe91 (patch)
treed144ff358845c0524ca84e4199b8389de3fa40bd /colm/Makefile.am
parent0ccd800d4f430bc53afa1cf358b7939d2616c68e (diff)
downloadcolm-d8cdec468bb7efad768d25872147533312cffe91.tar.gz
improvements to the ragel and colm config-time checks
Fixed the test of build_parsers that allows the ragel/colm check to function. Was checking for "true" when it should be a check for "yes". Added --with-* options for specifying where the packages are installed to.
Diffstat (limited to 'colm/Makefile.am')
-rw-r--r--colm/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/colm/Makefile.am b/colm/Makefile.am
index 19bb3dc1..c4a3504a 100644
--- a/colm/Makefile.am
+++ b/colm/Makefile.am
@@ -75,15 +75,15 @@ version.h: Makefile
if BUILD_PARSERS
lmparse.h: lmparse.kh
- kelbt -o $@ $<
+ $(KELBT) -o $@ $<
lmparse.cc: lmparse.kl lmparse.kh
- kelbt -o $@ $<
+ $(KELBT) -o $@ $<
lmscan.cc: lmparse.h
lmscan.cc: lmscan.rl
- ragel -G2 -o $@ $<
+ $(RAGEL) -G2 -o $@ $<
endif