summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKonstantin Podsvirov <konstantin@podsvirov.pro>2018-01-27 11:39:02 +0300
committerKonstantin Podsvirov <konstantin@podsvirov.pro>2018-01-29 18:24:10 +0300
commit108de08b4283b7cbc522e4de9604d785349bad03 (patch)
tree3db0841212120b32eb0baf919cab6155ab4c5d6e /configure.ac
parent1a25592250954f460a811805f5537d7d1198294b (diff)
downloadcolm-108de08b4283b7cbc522e4de9604d785349bad03.tar.gz
Add CMake project
Now implemented: - Bootstrap `colm` program from sources; - Install target `colm::coml` and `colm::libcolm` via CMake's `colm` package. Shadow build support via CMake. Tested with MSYS2 and MinGW-w64 on Windows and with GCC on Linux. Detected issue when sizeof(word_t) < sizeof(void*).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 43e9f0af..ac545939 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,6 +32,7 @@ AC_CONFIG_MACRO_DIR([m4])
AC_SUBST(PUBDATE)
AC_CONFIG_HEADER([src/config.h src/defs.h])
+AC_CHECK_HEADERS([sys/mman.h sys/wait.h unistd.h])
dnl Choose a default for the build_manual var. If the dist file is present in
dnl the root then default to no, otherwise go for it.