summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAdrian Thurston <thurston@colm.net>2019-09-09 14:14:36 -0600
committerAdrian Thurston <thurston@colm.net>2019-09-09 14:14:36 -0600
commit651e173a5924f6602bbd13f25529183ca04c9dc6 (patch)
treeb456e340f0decf9859e4a30f8cfc1aa30739e256 /configure.ac
parent88e43d6a720e089ab945a1e9fdeca6558e66cd5b (diff)
downloadcolm-651e173a5924f6602bbd13f25529183ca04c9dc6.tar.gz
getting test cases running
Setting up SED_SUBST and the ragel/colm build vars. Previously these were populated by configure options. Now pointing to locations in the same tree.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d091832d..16036280 100644
--- a/configure.ac
+++ b/configure.ac
@@ -111,6 +111,14 @@ dnl AM_CONDITIONAL([BUILD_MANUAL], [test "x$build_manual" = "xyes"])
AC_CANONICAL_HOST()
AM_CONDITIONAL([LINKER_NO_UNDEFINED], [test "x$host_os" = "xlinux-gnu"])
+AC_ARG_WITH(crack,
+ [AC_HELP_STRING([--with-crack], [location of crack install])],
+ [CRACK_BIN="$withval/bin/crack"],
+ [AC_ERROR(["require --with-crack"])]
+)
+
+AC_SUBST(CRACK_BIN)
+
COLM='$(top_srcdir)/colm/colm'
COLM_LD='$(top_srcdir)/colm/libcolm.la'
COLM_LIBDEP=$COLM_LD
@@ -121,6 +129,14 @@ AC_SUBST(COLM_LD)
AC_SUBST(COLM_LIBDEP)
AC_SUBST(COLM_BINDEP)
+SED_SUBST=["\
+ -e 's|@CRACK_BIN@|${CRACK_BIN}|g' \
+ -e 's|@CXX@|${CXX}|g' \
+ -e 's|@CC@|${CC}|g' \
+"]
+
+AC_SUBST(SED_SUBST)
+
dnl write output files
AC_OUTPUT([
Makefile