summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAdrian Thurston <thurston@colm.net>2019-09-09 18:00:05 -0600
committerAdrian Thurston <thurston@colm.net>2019-09-09 18:07:40 -0600
commit6e379ead8f003650a162790b9f3a78fa5d7b22a6 (patch)
treebe5dcd5ac4629bdddec5ac0d0a459fbfaf439112 /configure.ac
parent3fef8c775492d6164aa67fac2d815e65285ee445 (diff)
downloadcolm-6e379ead8f003650a162790b9f3a78fa5d7b22a6.tar.gz
the config.h file now goes to src
Any piece of the system may need to use config.h. Put that in /src and add -Isrc to CPPFLAGS. The colm package uses defs.h for configuration. It gets installed because some public headers depend on it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 16036280..238f0a1f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,7 +35,6 @@ AC_CHECK_SIZEOF(void *)
AC_CHECK_SIZEOF(long)
AC_CHECK_SIZEOF(unsigned long)
AC_CHECK_SIZEOF(unsigned long long)
-AC_CONFIG_HEADER([colm/config.h colm/defs.h])
AC_CHECK_HEADERS([sys/mman.h sys/wait.h unistd.h])
dnl Choose a default for the build_manual var. If the dist file is present in
@@ -129,6 +128,8 @@ AC_SUBST(COLM_LD)
AC_SUBST(COLM_LIBDEP)
AC_SUBST(COLM_BINDEP)
+CPPFLAGS="${CPPFLAGS} -I$(top_srcdir)/src"
+
SED_SUBST=["\
-e 's|@CRACK_BIN@|${CRACK_BIN}|g' \
-e 's|@CXX@|${CXX}|g' \
@@ -137,6 +138,8 @@ SED_SUBST=["\
AC_SUBST(SED_SUBST)
+AC_CONFIG_HEADERS([src/config.h colm/defs.h])
+
dnl write output files
AC_OUTPUT([
Makefile