summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAdrian Thurston <thurston@colm.net>2018-12-13 15:43:35 +0200
committerAdrian Thurston <thurston@colm.net>2018-12-13 15:43:35 +0200
commitfc1d61f4cab2260e90fcd468078eaa0d2046f372 (patch)
treee29f4f3321f86f7bdc479fb8bec84c50d7a7f31c /configure.ac
parent17991269d612fa8b1eb8ec6c43d072d813457a56 (diff)
downloadcolm-fc1d61f4cab2260e90fcd468078eaa0d2046f372.tar.gz
use -Wl,--no-undefined only on linux
refs #253
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index abcdb699..cf06b9bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -84,6 +84,9 @@ AC_CHECK_PROG([ASCIIDOC], [asciidoc], [asciidoc])
AC_CHECK_PROG([PYGMENTIZE], [pygmentize], [pygmentize])
AM_CONDITIONAL([BUILD_MANUAL], [test "x$ASCIIDOC" != x && test "x$PYGMENTIZE" != x])
+AC_CANONICAL_HOST()
+AM_CONDITIONAL([LINKER_NO_UNDEFINED], [test "x$host_os" = "xlinux-gnu"])
+
dnl write output files
AC_OUTPUT([
Makefile