summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAdrian Thurston <thurston@complang.org>2011-10-02 19:51:41 +0000
committerAdrian Thurston <thurston@complang.org>2011-10-02 19:51:41 +0000
commit9bdfd3a2190424f82700dd0813fdd1ad5f1d9850 (patch)
tree19d5a308c4e43151bbe2cfacdbc1d69ac04123ca /configure.in
parentdffd2f9603d92b4e376b15109ebc92b82f3e40d3 (diff)
downloadcolm-9bdfd3a2190424f82700dd0813fdd1ad5f1d9850.tar.gz
Leaks and memory errors fixed. If a disappearing fsm run has run buffers they
are transfered to the program and freed on exit.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 78f39515..fcf763ad 100644
--- a/configure.in
+++ b/configure.in
@@ -64,6 +64,9 @@ AC_PROG_MAKE_SET
AC_ARG_ENABLE(pool-malloc, "allocate pool objects with malloc",
AC_DEFINE([POOL_MALLOC], [1], [allocate pool objects with malloc]))
+AC_ARG_ENABLE(debug, "enable debug statements",
+ AC_DEFINE([DEBUG], [1], [enable debug statements]))
+
# Logging features
# AC_ARG_ENABLE(log, "turn on logging", AC_DEFINE(COLM_LOG))
# AC_ARG_ENABLE(log-bytecode, "turns on bytecode logging", AC_DEFINE(COLM_LOG_BYTECODE))