summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAdrian Thurston <thurston@complang.org>2013-12-25 20:57:24 -0500
committerAdrian Thurston <thurston@complang.org>2013-12-25 20:57:24 -0500
commit2625322bed9059f58ccb34b9db8b1347b9e9aa9f (patch)
treee5edee39a74eb232a01e2957444f134257bcfb3b /src/Makefile.am
parent6d2de7be625d3a44017adccf2abb68370e68f824 (diff)
downloadcolm-2625322bed9059f58ccb34b9db8b1347b9e9aa9f.tar.gz
can't use resolve for expr type lookups, use new class of funcs
Cannot mix type and expression lookups. Expression lookups won't necessarily succeed when the type lookups need to be called.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 4e50caf6..c39371bc 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -53,7 +53,7 @@ libprog_a_SOURCES = \
parsetree.h pcheck.h pdacodegen.h pdagraph.h pdarun.h pool.h redbuild.h \
redfsm.h rtvector.h tree.h version.h global.h colm.h parser.h cstring.h \
\
- resolve.cc synthesis.cc parsetree.cc \
+ resolve.cc lookup.cc synthesis.cc parsetree.cc \
fsmstate.cc fsmbase.cc fsmattach.cc fsmmin.cc \
fsmgraph.cc pdagraph.cc pdabuild.cc pdacodegen.cc fsmcodegen.cc \
redfsm.cc fsmexec.cc redbuild.cc closure.cc fsmap.cc \