summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorAdrian Thurston <thurston@complang.org>2011-11-23 07:16:15 +0000
committerAdrian Thurston <thurston@complang.org>2011-11-23 07:16:15 +0000
commit95c94d3cc8b40f072f92c70ef5eb5d6ed3c68cef (patch)
tree8ad8d4305c389cd2db855c5a740f7a62a4f41e56 /test/Makefile.am
parent41b5b699470b60381bb9b06e37d25144e91d778c (diff)
downloadcolm-95c94d3cc8b40f072f92c70ef5eb5d6ed3c68cef.tar.gz
Flattening tests. Not claiming any particular language.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am26
1 files changed, 21 insertions, 5 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 2c89a76c..4d0f3ca5 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,8 +1,7 @@
-DIST_SUBDIRS = python cxx ruby
-
TESTS = runtests.mk
TEST_CASES = \
+ ambig1.lm \
backtrack1.lm \
backtrack2.lm \
backtrack3.lm \
@@ -22,6 +21,8 @@ TEST_CASES = \
construct1.lm \
construct2.lm \
construct3.lm \
+ generate1.lm \
+ lookup1.lm \
treecmp1.lm \
context1.lm \
context2.lm \
@@ -51,7 +52,10 @@ TEST_CASES = \
counting3.lm \
counting4.lm \
til.lm \
- tags.lm \
+ tags1.lm \
+ tags2.lm \
+ tags3.lm \
+ tags4.lm \
matchex.lm \
maxlen.lm \
superid.lm \
@@ -65,6 +69,7 @@ TEST_CASES = \
multiregion2.lm
INPUT = \
+ ambig1.in \
accum1.in \
accum2.in \
backtrack1.in \
@@ -80,6 +85,8 @@ INPUT = \
counting2.in \
counting3.in \
counting4.in \
+ generate1.in \
+ lookup1.in \
binary1.in \
func.in \
heredoc.in \
@@ -99,7 +106,10 @@ INPUT = \
rubyhere.in \
string.in \
superid.in \
- tags.in \
+ tags1.in \
+ tags2.in \
+ tags3.in \
+ tags4.in \
til.in \
translate1.in \
translate2.in \
@@ -114,6 +124,7 @@ INPUT = \
multiregion2.in
EXPECTED_OUTPUT = \
+ ambig1.exp \
accum1.exp \
accum2.exp \
accum3.exp \
@@ -137,6 +148,8 @@ EXPECTED_OUTPUT = \
counting2.exp \
counting3.exp \
counting4.exp \
+ generate1.exp \
+ lookup1.exp \
div.exp \
binary1.exp \
exit1.exp \
@@ -162,7 +175,10 @@ EXPECTED_OUTPUT = \
sprintf.exp \
string.exp \
superid.exp \
- tags.exp \
+ tags1.exp \
+ tags2.exp \
+ tags3.exp \
+ tags4.exp \
til.exp \
translate1.exp \
translate2.exp \