summaryrefslogtreecommitdiff
path: root/test/rlhc.d/Makefile.am
diff options
context:
space:
mode:
authorVictor Westerhuis <victor@westerhu.is>2021-12-03 23:33:32 +0100
committerVictor Westerhuis <victor@westerhu.is>2021-12-04 01:08:24 +0100
commit5f674757fc35708f7d1700a9fc37a7b77a1bf1ab (patch)
treeea7ae10876599431e5509ba5007ce890050cc706 /test/rlhc.d/Makefile.am
parent5cf37adb380b4ddf819951913c4d3044071f7e6b (diff)
downloadcolm-5f674757fc35708f7d1700a9fc37a7b77a1bf1ab.tar.gz
Only build tests when running check
Change noinst_ targets to check_. Also move from BUILT_SOURCES to explicit dependencies to prevent running colm when not running tests.
Diffstat (limited to 'test/rlhc.d/Makefile.am')
-rw-r--r--test/rlhc.d/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/test/rlhc.d/Makefile.am b/test/rlhc.d/Makefile.am
index 4c8e841d..59999192 100644
--- a/test/rlhc.d/Makefile.am
+++ b/test/rlhc.d/Makefile.am
@@ -16,7 +16,7 @@ RLHC_DEP = \
EXTRA_DIST = gentests rlhc.lm $(RLHC_DEP) $(CASES)
-noinst_PROGRAMS = rlhc
+check_PROGRAMS = rlhc
rlhc$(EXEEXT): rlhc.lm $(RLHC_DEP) $(COLM_BIN)
$(COLM_BIN) -B '$(top_builddir)' -b rlhc_object -o $@ -I$(srcdir) $<
@@ -1094,10 +1094,8 @@ CLEANFILES = gentests
clean-local:
rm -Rf working case
-all-local:
+check-local:
if test '$(builddir)' != '$(srcdir)'; then \
$(LN_S) -f '$(srcdir)/gentests' '$(srcdir)/case' '$(builddir)'; \
fi
-
-check-local:
'$(top_srcdir)/test/runtests'