summaryrefslogtreecommitdiff
path: root/colm/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'colm/CMakeLists.txt')
-rw-r--r--colm/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/colm/CMakeLists.txt b/colm/CMakeLists.txt
index fb84401d..3d855523 100644
--- a/colm/CMakeLists.txt
+++ b/colm/CMakeLists.txt
@@ -143,6 +143,14 @@ add_executable(colm
"${CMAKE_CURRENT_BINARY_DIR}/gen/parse3.c"
"${CMAKE_CURRENT_BINARY_DIR}/gen/if3.cc")
+if(BUILD_STANDALONE)
+ if(CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
+ target_link_libraries(colm -static)
+ else()
+ message(FATAL_ERROR "Unsupported toolset for standalone build.")
+ endif()
+endif()
+
target_link_libraries(colm libprog libcolm)
set_property(TARGET colm APPEND PROPERTY