summaryrefslogtreecommitdiff
path: root/test/colm.d/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/colm.d/Makefile.am')
-rw-r--r--test/colm.d/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/test/colm.d/Makefile.am b/test/colm.d/Makefile.am
index e2a4c911..b0041329 100644
--- a/test/colm.d/Makefile.am
+++ b/test/colm.d/Makefile.am
@@ -1,4 +1,4 @@
-noinst_SCRIPTS = gentests
+check_SCRIPTS = gentests
EXTRA_DIST = \
gentests.sh \
@@ -185,6 +185,13 @@ EXTRA_DIST = \
gentests: gentests.sh Makefile
@$(top_srcdir)/sedsubst $< $@ -w,+x $(SED_SUBST)
+CLEANFILES = gentests
+
clean-local:
- rm -Rf working
+ rm -Rf working *.lm *.lmi *.in
+check-local:
+ if test '$(builddir)' != '$(srcdir)'; then \
+ $(LN_S) -f '$(srcdir)/'*.lm '$(srcdir)/'*.lmi '$(srcdir)/'*.in '$(builddir)'; \
+ fi
+ '$(top_srcdir)/test/runtests'