summaryrefslogtreecommitdiff
path: root/test/python/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/python/Makefile.am')
-rw-r--r--test/python/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/test/python/Makefile.am b/test/python/Makefile.am
new file mode 100644
index 00000000..158d14fb
--- /dev/null
+++ b/test/python/Makefile.am
@@ -0,0 +1,52 @@
+SUBDIRS =
+
+TESTS = \
+ python.lm
+
+DIFFS = \
+ python1.py.diff \
+ python2.py.diff \
+ python3.py.diff \
+ python4.py.diff
+
+all: Makefile $(DIFFS) $(SUBDIRS)
+
+.PHONY: clean $(SUBDIRS:%=%-clean)
+clean: $(SUBDIRS:%=%-clean)
+ rm -f *.bin
+$(SUBDIRS:%=%-clean):
+ cd $(@:%-clean=%) && $(MAKE) clean
+
+.PHONY: $(SUBDIRS)
+$(SUBDIRS):
+ cd $@ && $(MAKE)
+
+Makefile: ../genmf TESTS
+ ../genmf > Makefile
+
+python1.py.diff: python1.py.out python1.py.exp
+ @diff -u python1.py.exp python1.py.out > python1.py.diff || ( cat python1.py.diff; rm python1.py.diff )
+
+python1.py.out: python.bin
+ ./python.bin < python1.py.in > python1.py.out
+
+python2.py.diff: python2.py.out python2.py.exp
+ @diff -u python2.py.exp python2.py.out > python2.py.diff || ( cat python2.py.diff; rm python2.py.diff )
+
+python2.py.out: python.bin
+ ./python.bin < python2.py.in > python2.py.out
+
+python3.py.diff: python3.py.out python3.py.exp
+ @diff -u python3.py.exp python3.py.out > python3.py.diff || ( cat python3.py.diff; rm python3.py.diff )
+
+python3.py.out: python.bin
+ ./python.bin < python3.py.in > python3.py.out
+
+python4.py.diff: python4.py.out python4.py.exp
+ @diff -u python4.py.exp python4.py.out > python4.py.diff || ( cat python4.py.diff; rm python4.py.diff )
+
+python4.py.out: python.bin
+ ./python.bin < python4.py.in > python4.py.out
+
+python.bin: python.lm ../../colm/colm
+ ../../colm/colm python.lm