summaryrefslogtreecommitdiff
path: root/test/rlhc.d/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/rlhc.d/Makefile.am')
-rw-r--r--test/rlhc.d/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/test/rlhc.d/Makefile.am b/test/rlhc.d/Makefile.am
index 4c8e841d..59999192 100644
--- a/test/rlhc.d/Makefile.am
+++ b/test/rlhc.d/Makefile.am
@@ -16,7 +16,7 @@ RLHC_DEP = \
EXTRA_DIST = gentests rlhc.lm $(RLHC_DEP) $(CASES)
-noinst_PROGRAMS = rlhc
+check_PROGRAMS = rlhc
rlhc$(EXEEXT): rlhc.lm $(RLHC_DEP) $(COLM_BIN)
$(COLM_BIN) -B '$(top_builddir)' -b rlhc_object -o $@ -I$(srcdir) $<
@@ -1094,10 +1094,8 @@ CLEANFILES = gentests
clean-local:
rm -Rf working case
-all-local:
+check-local:
if test '$(builddir)' != '$(srcdir)'; then \
$(LN_S) -f '$(srcdir)/gentests' '$(srcdir)/case' '$(builddir)'; \
fi
-
-check-local:
'$(top_srcdir)/test/runtests'