summaryrefslogtreecommitdiff
path: root/test/xml/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/xml/Makefile.am')
-rw-r--r--test/xml/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/test/xml/Makefile.am b/test/xml/Makefile.am
new file mode 100644
index 00000000..e5b290fd
--- /dev/null
+++ b/test/xml/Makefile.am
@@ -0,0 +1,31 @@
+SUBDIRS =
+
+TESTS = \
+ xml.lm
+
+DIFFS = \
+ xml.diff
+
+all: Makefile $(DIFFS) $(SUBDIRS)
+
+.PHONY: clean $(SUBDIRS:%=%-clean)
+clean: $(SUBDIRS:%=%-clean)
+ rm -f *.bin
+$(SUBDIRS:%=%-clean):
+ cd $(@:%-clean=%) && $(MAKE) clean
+
+.PHONY: $(SUBDIRS)
+$(SUBDIRS):
+ cd $@ && $(MAKE)
+
+Makefile: ../genmf TESTS
+ ../genmf > Makefile
+
+xml.diff: xml.out xml.exp
+ @diff -u xml.exp xml.out > xml.diff || ( cat xml.diff; rm xml.diff )
+
+xml.out: xml.bin
+ ./xml.bin < xml.in > xml.out
+
+xml.bin: xml.lm ../../colm/colm
+ ../../colm/colm xml.lm